import Foundation
let pattern = #"Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)