package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Client Name: (?<client_name>[\w\W]+?)\s+Client Question: (?<client_question>[\w\W]+?)\s+Additional Info: (?<additional_info>[\w\W]+?)\s+Attachments:`)
var str = `Client Name: Client
Client Question: Question
Additional Info: Additional INfo
Attachments:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}