const regex = /^(?:\[(?'id'[0-9]+)\])?(?'name'[^[.]+|.+)?(?:\[(?'data'[.\-:0-9 ]+)\])?(?'ext'\.[.a-zA-Z]+)+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\[(?\'id\'[0-9]+)\\])?(?\'name\'[^[.]+|.+)?(?:\\[(?\'data\'[.\\-:0-9 ]+)\\])?(?\'ext\'\\.[.a-zA-Z]+)+$', 'mg')
const str = `[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
[][].zip
[].zip
.zip
.zip.zip
[]~[1.1,+'_!@#\$%^&()].zip
hello[23.12.2020 13-34]world.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}