// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\[(?'id'[0-9]+)\])?(?'name'[^[.]+|.+)?(?:\[(?'data'[.\-:0-9 ]+)\])?(?'ext'\.[.a-zA-Z]+)+$").unwrap();
let string = "[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
[][].zip
[].zip
.zip
.zip.zip
[]~[1.1,+'_!@#$%^&()].zip
hello[23.12.2020 13-34]world.zip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}