#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}"
Local $sString = "0#lo__EmailWrapperCache_payquicker.hydra_en-US" & @CRLF & _
"0#lo__EmailWrapperCache_payquicker.holodeck_en-US" & @CRLF & _
"2#lo__EmailWrapperCache_payquicker.holodeck_en-US" & @CRLF & _
"0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")