import Foundation
let pattern = ##"\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
0#lo__EmailWrapperCache_payquicker.hydra_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_en-US
2#lo__EmailWrapperCache_payquicker.holodeck_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)