$re = '/\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}/m';
$str = '0#lo__EmailWrapperCache_payquicker.hydra_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_en-US
2#lo__EmailWrapperCache_payquicker.holodeck_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);