import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\\.[a-zA-Z0-9]+_\\w{2}-\\w{2}";
final String string = "0#lo__EmailWrapperCache_payquicker.hydra_en-US\n"
+ "0#lo__EmailWrapperCache_payquicker.holodeck_en-US\n"
+ "2#lo__EmailWrapperCache_payquicker.holodeck_en-US\n"
+ "0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}