use strict;
my $str = '0#lo__EmailWrapperCache_payquicker.hydra_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_en-US
2#lo__EmailWrapperCache_payquicker.holodeck_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR';
my $regex = qr/\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}