const regex = /\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\\.[a-zA-Z0-9]+_\\w{2}-\\w{2}', 'gm')
const str = `0#lo__EmailWrapperCache_payquicker.hydra_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_en-US
2#lo__EmailWrapperCache_payquicker.holodeck_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}