using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d#lo__EmailWrapperCache_[a-zA-Z0-9]+\.[a-zA-Z0-9]+_\w{2}-\w{2}";
string input = @"0#lo__EmailWrapperCache_payquicker.hydra_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_en-US
2#lo__EmailWrapperCache_payquicker.holodeck_en-US
0#lo__EmailWrapperCache_payquicker.holodeck_pt-BR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}