import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Src\\/High\\/SS\\/(?!FormCalc).+";
final String string = "Src/High/SS/ATG_Help \n"
+ "Src/High/SS/ConvCalc \n"
+ "Src/High/SS/ConvX \n"
+ "Src/High/SS/EFiling \n"
+ "Src/High/SS/Edit \n"
+ "Src/High/SS/FormCalc \n"
+ "Src/High/SS/FormDisp \n"
+ "Src/High/SS/Image \n"
+ "Src/High/SS/Import \n"
+ "Src/High/SS/Importables \n"
+ "Src/High/SS/Intrview \n"
+ "Src/High/SS/Intrview/Dialog \n"
+ "Src/High/SS/Intrview/Dialog/Facades \n"
+ "Src/High/SS/Intrview/Dialog/Facades/PrivateHeaders \n"
+ "Src/High/SS/Intrview/Dialog/PrivateHeaders \n"
+ "Src/High/SS/Misc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}