import Foundation
let pattern = #"Src\/High\/SS\/(?!FormCalc).+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Src/High/SS/ATG_Help
Src/High/SS/ConvCalc
Src/High/SS/ConvX
Src/High/SS/EFiling
Src/High/SS/Edit
Src/High/SS/FormCalc
Src/High/SS/FormDisp
Src/High/SS/Image
Src/High/SS/Import
Src/High/SS/Importables
Src/High/SS/Intrview
Src/High/SS/Intrview/Dialog
Src/High/SS/Intrview/Dialog/Facades
Src/High/SS/Intrview/Dialog/Facades/PrivateHeaders
Src/High/SS/Intrview/Dialog/PrivateHeaders
Src/High/SS/Misc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)