const regex = /Src\/High\/SS\/(?!FormCalc).+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Src\\\/High\\\/SS\\\/(?!FormCalc).+', 'g')
const str = `Src/High/SS/ATG_Help
Src/High/SS/ConvCalc
Src/High/SS/ConvX
Src/High/SS/EFiling
Src/High/SS/Edit
Src/High/SS/FormCalc
Src/High/SS/FormDisp
Src/High/SS/Image
Src/High/SS/Import
Src/High/SS/Importables
Src/High/SS/Intrview
Src/High/SS/Intrview/Dialog
Src/High/SS/Intrview/Dialog/Facades
Src/High/SS/Intrview/Dialog/Facades/PrivateHeaders
Src/High/SS/Intrview/Dialog/PrivateHeaders
Src/High/SS/Misc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}