# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Src\/High\/SS\/(?!FormCalc).+"
test_str = ("Src/High/SS/ATG_Help \n"
"Src/High/SS/ConvCalc \n"
"Src/High/SS/ConvX \n"
"Src/High/SS/EFiling \n"
"Src/High/SS/Edit \n"
"Src/High/SS/FormCalc \n"
"Src/High/SS/FormDisp \n"
"Src/High/SS/Image \n"
"Src/High/SS/Import \n"
"Src/High/SS/Importables \n"
"Src/High/SS/Intrview \n"
"Src/High/SS/Intrview/Dialog \n"
"Src/High/SS/Intrview/Dialog/Facades \n"
"Src/High/SS/Intrview/Dialog/Facades/PrivateHeaders \n"
"Src/High/SS/Intrview/Dialog/PrivateHeaders \n"
"Src/High/SS/Misc")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.