re = /Src\/High\/SS\/(?!FormCalc).+/
str = 'Src/High/SS/ATG_Help
Src/High/SS/ConvCalc
Src/High/SS/ConvX
Src/High/SS/EFiling
Src/High/SS/Edit
Src/High/SS/FormCalc
Src/High/SS/FormDisp
Src/High/SS/Image
Src/High/SS/Import
Src/High/SS/Importables
Src/High/SS/Intrview
Src/High/SS/Intrview/Dialog
Src/High/SS/Intrview/Dialog/Facades
Src/High/SS/Intrview/Dialog/Facades/PrivateHeaders
Src/High/SS/Intrview/Dialog/PrivateHeaders
Src/High/SS/Misc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end