#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}"
Local $sString = "<html>" & @CRLF & _
" <head><title>{title}</title></head>" & @CRLF & _
" <body>" & @CRLF & _
" <h1>{header}</h1>" & @CRLF & _
" <ul>" & @CRLF & _
" {#each item in items}" & @CRLF & _
" <li>{item.name}: {item.value}</li>" & @CRLF & _
" {/each}" & @CRLF & _
" </ul>" & @CRLF & _
" <footer>{footer}</footer>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")