# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}"
test_str = ("<html>\n"
" <head><title>{title}</title></head>\n"
" <body>\n"
" <h1>{header}</h1>\n"
" <ul>\n"
" {#each item in items}\n"
" <li>{item.name}: {item.value}</li>\n"
" {/each}\n"
" </ul>\n"
" <footer>{footer}</footer>\n"
" </body>\n"
"</html>")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.