using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}";
string input = @"<html>
<head><title>{title}</title></head>
<body>
<h1>{header}</h1>
<ul>
{#each item in items}
<li>{item.name}: {item.value}</li>
{/each}
</ul>
<footer>{footer}</footer>
</body>
</html>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}