// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}").unwrap();
let string = "<html>
<head><title>{title}</title></head>
<body>
<h1>{header}</h1>
<ul>
{#each item in items}
<li>{item.name}: {item.value}</li>
{/each}
</ul>
<footer>{footer}</footer>
</body>
</html>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}