const regex = /\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\s*#each\\s+(\\w+)\\s+in\\s+(\\w+)\\s*\\}([\\s\\S]*?)\\{\\s*\\\/each\\s*\\}', 'i')
const str = `<html>
<head><title>{title}</title></head>
<body>
<h1>{header}</h1>
<ul>
{#each item in items}
<li>{item.name}: {item.value}</li>
{/each}
</ul>
<footer>{footer}</footer>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}