$re = '/\{\s*#each\s+(\w+)\s+in\s+(\w+)\s*\}([\s\S]*?)\{\s*\/each\s*\}/i';
$str = '<html>
<head><title>{title}</title></head>
<body>
<h1>{header}</h1>
<ul>
{#each item in items}
<li>{item.name}: {item.value}</li>
{/each}
</ul>
<footer>{footer}</footer>
</body>
</html>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);