import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*#each\\s+(\\w+)\\s+in\\s+(\\w+)\\s*\\}([\\s\\S]*?)\\{\\s*\\/each\\s*\\}";
final String string = "<html>\n"
+ " <head><title>{title}</title></head>\n"
+ " <body>\n"
+ " <h1>{header}</h1>\n"
+ " <ul>\n"
+ " {#each item in items}\n"
+ " <li>{item.name}: {item.value}</li>\n"
+ " {/each}\n"
+ " </ul>\n"
+ " <footer>{footer}</footer>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}