#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)"
Local $sString = "11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung" & @CRLF & _
"" & @CRLF & _
"N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")