import Foundation
let pattern = ##"^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)