// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)").unwrap();
let string = "11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}