import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<latitude>[N|S]\\d+)(?<longtitude>[E|W]\\d+),(?<einsatznr>\\d+),(?<beschreibung>(.+))\\s(?<ort1>.*?),\\s(?<strasse1>.*?),\\s#(?<strasse2>.*?)\\s(?<ort2>.*?),\\s(?<gemeinde>.*?),(?<textmeldung>.*)";
final String string = "11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung\n\n"
+ "N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}