$re = '/^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)/m';
$str = '11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);