#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"Main_Message__c":"(?<mainmess>.*?)".*?"
Local $sString = "{"totalSize":1,"done":true,"records":[{"attributes":{"type":"inContact_Message_Management__c","url":"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG"},"Main_Message__c":"Normal"}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")