use strict;
my $str = '{"totalSize":1,"done":true,"records":[{"attributes":{"type":"inContact_Message_Management__c","url":"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG"},"Main_Message__c":"Normal"}]}';
my $regex = qr/"Main_Message__c":"(?<mainmess>.*?)".*?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}