// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Main_Message__c":"(?<mainmess>.*?)".*?"#).unwrap();
let string = "{\"totalSize\":1,\"done\":true,\"records\":[{\"attributes\":{\"type\":\"inContact_Message_Management__c\",\"url\":\"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG\"},\"Main_Message__c\":\"Normal\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}