package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"Main_Message__c":"(?<mainmess>.*?)".*?`)
var str = `{"totalSize":1,"done":true,"records":[{"attributes":{"type":"inContact_Message_Management__c","url":"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG"},"Main_Message__c":"Normal"}]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}