$re = '/"Main_Message__c":"(?<mainmess>.*?)".*?/m';
$str = '{"totalSize":1,"done":true,"records":[{"attributes":{"type":"inContact_Message_Management__c","url":"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG"},"Main_Message__c":"Normal"}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);