using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Main_Message__c"":""(?<mainmess>.*?)"".*?";
string input = @"{""totalSize"":1,""done"":true,""records"":[{""attributes"":{""type"":""inContact_Message_Management__c"",""url"":""/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG""},""Main_Message__c"":""Normal""}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}