import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Main_Message__c\":\"(?<mainmess>.*?)\".*?";
final String string = "{\"totalSize\":1,\"done\":true,\"records\":[{\"attributes\":{\"type\":\"inContact_Message_Management__c\",\"url\":\"/services/data/v43.0/sobjects/inContact_Message_Management__c/a2RC0000000JJbvMAG\"},\"Main_Message__c\":\"Normal\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}