#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\@(.{2,}\.)+.{2,}"
Local $sString = "p@post.de" & @CRLF & _
"wer@wer.wersdf.de" & @CRLF & _
"sdf@asd.co.uk" & @CRLF & _
"post@mycompany.de" & @CRLF & _
"j@wearehere.de" & @CRLF & _
"info@db.de" & @CRLF & _
"// not valid:" & @CRLF & _
"p@wwer.d" & @CRLF & _
"a@d.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")