import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\@(.{2,}\\.)+.{2,}";
final String string = "p@post.de\n"
+ "wer@wer.wersdf.de\n"
+ "sdf@asd.co.uk\n"
+ "post@mycompany.de\n"
+ "j@wearehere.de\n"
+ "info@db.de\n"
+ "// not valid:\n"
+ "p@wwer.d\n"
+ "a@d.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}