package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\@(.{2,}\.)+.{2,}`)
var str = `p@post.de
wer@wer.wersdf.de
sdf@asd.co.uk
post@mycompany.de
j@wearehere.de
info@db.de
// not valid:
p@wwer.d
a@d.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}