using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\@(.{2,}\.)+.{2,}";
string input = @"p@post.de
wer@wer.wersdf.de
sdf@asd.co.uk
post@mycompany.de
j@wearehere.de
info@db.de
// not valid:
p@wwer.d
a@d.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}