// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\@(.{2,}\.)+.{2,}").unwrap();
let string = "p@post.de
wer@wer.wersdf.de
sdf@asd.co.uk
post@mycompany.de
j@wearehere.de
info@db.de
// not valid:
p@wwer.d
a@d.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}