re = /.*\@(.{2,}\.)+.{2,}/
str = 'p@post.de
wer@wer.wersdf.de
sdf@asd.co.uk
post@mycompany.de
j@wearehere.de
info@db.de
// not valid:
p@wwer.d
a@d.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end