$re = '/.*\@(.{2,}\.)+.{2,}/';
$str = 'p@post.de
wer@wer.wersdf.de
sdf@asd.co.uk
post@mycompany.de
j@wearehere.de
info@db.de
// not valid:
p@wwer.d
a@d.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);