#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n"
Local $sString = "===============" & @CRLF & _
"celine.denecke@gmx.de:x1xc2xx1" & @CRLF & _
"Games:" & @CRLF & _
"- Summoners War: Sky Arena" & @CRLF & _
"- Dragon Blaze" & @CRLF & _
"Game friends:" & @CRLF & _
"- 68" & @CRLF & _
"===============" & @CRLF & _
"celine.denecke@gmx.de:x1xc2xx1" & @CRLF & _
"Games:" & @CRLF & _
"- Summoners War: Sky Arena" & @CRLF & _
"- Dragon Blaze" & @CRLF & _
"Game friends:" & @CRLF & _
"- 18" & @CRLF & _
"===============" & @CRLF & _
"celine.denecke@gmx.de:x1xc2xx1" & @CRLF & _
"Games:" & @CRLF & _
"- Summoners War: Sky Arena" & @CRLF & _
"- Dragon Blaze" & @CRLF & _
"Game friends:" & @CRLF & _
"- 68" & @CRLF & _
"===============" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")