import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^===============\\n[^=]*^Game friends:\\n^- (?:\\d|1\\d)\\n";
final String string = "===============\n"
+ "celine.denecke@gmx.de:x1xc2xx1\n"
+ "Games:\n"
+ "- Summoners War: Sky Arena\n"
+ "- Dragon Blaze\n"
+ "Game friends:\n"
+ "- 68\n"
+ "===============\n"
+ "celine.denecke@gmx.de:x1xc2xx1\n"
+ "Games:\n"
+ "- Summoners War: Sky Arena\n"
+ "- Dragon Blaze\n"
+ "Game friends:\n"
+ "- 18\n"
+ "===============\n"
+ "celine.denecke@gmx.de:x1xc2xx1\n"
+ "Games:\n"
+ "- Summoners War: Sky Arena\n"
+ "- Dragon Blaze\n"
+ "Game friends:\n"
+ "- 68\n"
+ "===============\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}