package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n`)
var str = `===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 18
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}