import Foundation
let pattern = #"^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 18
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)