// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n").unwrap();
let string = "===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 18
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}