const regex = new RegExp('^<p>(.*)</p>$', 'gm')
const str = `<p><p>{'Area': 'Square',</p>\\n<p> <tr> <td>'Flag': 'com'}</p></p>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);