use strict;
my $str = '<p><p>{\'Area\': \'Square\',</p>\\n<p> <tr> <td>\'Flag\': \'com\'}</p></p>';
my $regex = qr/^<p>(.*)</p>$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";