import re
regex = re.compile(r"^<p>(.*)</p>$", flags=re.MULTILINE)
test_str = "<p><p>{'Area': 'Square',</p>\\n<p> <tr> <td>'Flag': 'com'}</p></p>"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)